fix(deps): pin Koffi to the tested release

Packed consumers resolved ^3.1.0 to 3.3.2, whose source build fails under the Linux release check. Pin every consumer to the existing lockfile version 3.1.1 so published installs use the tested dependency.
This commit is contained in:
gengruilin committed 2026-09-28 11:16:17 +08:00
1 parent 90cc7ce652
commit aee3c39ee7
8 files changed
+14 -14

No files matched your search

+1 -1
View File
@@ -61,7 +61,7 @@
"electron-builder": "^26.15.3",
"extract-zip": "^2.0.1",
"js-yaml": "^4.2.0",
"koffi": "^3.1.0",
"koffi": "3.1.1",
"pnpm": "11.7.0",
"sharp": "^0.35.3",
"typescript": "^6.0.3",
+1 -1
View File
@@ -32,7 +32,7 @@
},
"dependencies": {
"chokidar": "^4.0.3",
"koffi": "^3.1.0",
"koffi": "3.1.1",
"@deepseek-ai/schemastery": "workspace:~"
},
"devDependencies": {
@@ -34,7 +34,7 @@
"dependencies": {
"@deepseek-ai/dsh-host-directory-picker": "workspace:*",
"@deepseek-ai/dsh-native-command": "workspace:*",
"koffi": "^3.1.0"
"koffi": "3.1.1"
},
"peerDependencies": {
"@deepseek-ai/cordis": "workspace:~"
@@ -39,7 +39,7 @@
"dependencies": {
"@deepseek-ai/dsh-lazy-require": "workspace:*",
"@deepseek-ai/dsh-win32-process": "workspace:*",
"koffi": "^3.1.0"
"koffi": "3.1.1"
},
"devDependencies": {
"@deepseek-ai/dsh-pwsh-local": "workspace:*",
@@ -39,7 +39,7 @@
"@deepseek-ai/dsh-session-format-v3-to-v4": "workspace:*",
"@deepseek-ai/node-addon-system": "workspace:~",
"@deepseek-ai/schemastery": "workspace:~",
"koffi": "^3.1.0"
"koffi": "3.1.1"
},
"devDependencies": {
"@deepseek-ai/dsh-session": "workspace:*",
@@ -49,7 +49,7 @@
"dependencies": {
"@deepseek-ai/dsh-lazy-require": "workspace:*",
"@deepseek-ai/dsh-win32-process": "workspace:*",
"koffi": "^3.1.0",
"koffi": "3.1.1",
"node-pty": "1.2.0-beta.15"
},
"devDependencies": {
@@ -31,7 +31,7 @@
},
"dependencies": {
"@deepseek-ai/dsh-lazy-require": "workspace:*",
"koffi": "^3.1.0"
"koffi": "3.1.1"
},
"devDependencies": {
"@deepseek-ai/cordis": "workspace:~"
+7 -7
View File
@@ -667,7 +667,7 @@ importers:
specifier: ^4.2.0
version: 4.3.1
koffi:
specifier: ^3.1.0
specifier: 3.1.1
version: 3.1.1
pnpm:
specifier: 11.7.0
@@ -8389,7 +8389,7 @@ importers:
specifier: ^4.0.3
version: 4.0.3
koffi:
specifier: ^3.1.0
specifier: 3.1.1
version: 3.1.1
devDependencies:
'@deepseek-ai/cordis':
@@ -8991,7 +8991,7 @@ importers:
specifier: workspace:*
version: link:../../util/native-command
koffi:
specifier: ^3.1.0
specifier: 3.1.1
version: 3.1.1
devDependencies:
'@deepseek-ai/cordis':
@@ -10279,7 +10279,7 @@ importers:
specifier: workspace:*
version: link:../../subprocess/win32-process
koffi:
specifier: ^3.1.0
specifier: 3.1.1
version: 3.1.1
devDependencies:
'@deepseek-ai/cordis':
@@ -10889,7 +10889,7 @@ importers:
specifier: link:../../../vendor/schemastery
version: link:../../../vendor/schemastery
koffi:
specifier: ^3.1.0
specifier: 3.1.1
version: 3.1.1
devDependencies:
'@deepseek-ai/cordis':
@@ -12746,7 +12746,7 @@ importers:
specifier: workspace:*
version: link:../win32-process
koffi:
specifier: ^3.1.0
specifier: 3.1.1
version: 3.1.1
node-pty:
specifier: 1.2.0-beta.15
@@ -12771,7 +12771,7 @@ importers:
specifier: workspace:*
version: link:../../util/lazy-require
koffi:
specifier: ^3.1.0
specifier: 3.1.1
version: 3.1.1
devDependencies:
'@deepseek-ai/cordis':